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NOTE: This guide has been conceived in a progressive manner. You should go through 

it as it is written, since it is assumed that you already know how to do and interpret 

the examples given in previous sections. 

 

  



Theoretical background 

The reduced density gradient 

NCI (Non-Covalent Interactions) is a visualization index based on the density and 

its derivatives. It enables identification of non-covalent interactions. It is based on 

the peaks that appear in the reduced density gradient (RDG) at low densities. The 

reduced density gradient is given by: 

𝑠(𝑟) = 𝑐
|∇𝜌(𝑟)|

𝜌(𝑟)4/3
 

where c is a constant. RDG enables to reveal the non-covalent interactions. When 

we plot the RDG as a function of the density across a molecule, we see that the 

main difference between the monomer (Figure 1a) and dimer (Figure 1b) cases is 

the appearance of steep peaks at low density. 

 

 

a) Formic acid b) Formic acid dimer 

Figure 1. s() for formic a) acid and b) formic acid dimer. The 3D representation of the peaks at low 

density is given in the insets: they appear in the dimer for the non-covalent interactions. 

When we search for the points in 3D space giving rise to these peaks, non-covalent 

regions clearly appear in the (supra)molecular complex (insets in Figures 1a and 

1b). They appear for the dimer case (Figure 1b) and reveal the non-covalent 

interactions: the hydrogen bonds (in blue) and the van der Waals interactions (in 

green). The coloring has been carried out in terms of the electron density. As we 

can see in Figure 1b, two peaks appear, a sharp one at very low densities which 

corresponds to the van der Waals interaction (the green isosurface) and a wider one 

at greater densities which corresponds to the symmetric hydrogen bonds (in blue). 



The second eigenvalue 

 

The interactions revealed by NCI correspond to both favourable and unfavourable 

interactions. In order to differentiate between them, the sign of the second density 

Hessian eigenvalue times the density is implemented. This value is able to 

characterize the strength of the interaction by means of the density, and its 

curvature thanks to the sign of the second eigenvalue. Some examples are collected 

in Figure 2. It can be seen that the method is applicable to small molecules as well 

as inorganic complexes. 

 

Figure 2. NCI isosurfaces colored according to sign(2). From left to right: (top) benzene dimer, branched 

octane. (bottom) formic acid dimer, bicyclooctene, water dimer and methane dimer.  

Promolecular densities 

NCI (Non-Covalent Interactions) is applicable to promolecular densities, enabling 

the analysis of biomolecules (Figure 3). In this case, only the atomic coordinates 

are required as input. Both options (SCF and promolecular are implemented in the 

NCIPLOT). 



 

Figure 3. NCI isosurfaces from promolecular densities. Top left: -helix, bottom left: -sheet, right: DNA 

double helix.  

Practical session guide 

Preliminary step: the wavefunction file 
Set out=wfn in the Route section and give the name of the wfn file at the end of the molecule 

specification. 

The title first word (contiguous non blank characters) are used to form the file names in, it might be 

dangerous to use non alphanumerical characters. 

 

Example: C4H4 tetrahedrane 

 
# P HF/6-311++G(2df,2p) opt out=wfn 

tetrahedrane 

0,1 

C -0.524831 0.524831 0.524831 

C 0.524831 -0.524831 0.524831 

C -0.524831 -0.524831 -0.524831 

C 0.524831 0.524831 -0.524831 

H -1.134794 1.134794 1.134794 

H 1.134794 -1.134794 1.134794 

H -1.134794 -1.134794 -1.134794 

H 1.134794 1.134794 -1.134794 

 

tetrahedrane.wfn 

 



Obtaining NCI 
Two options are given for Linux or Windows users. NCIPLOT allows to obtain all the features needed 

for the practical session. If you don’t have access to a linux machine, you can install a public license 

for AIMALL which will allow you to carry out the first part of the TP. 

Option 1: NCIPLOT (Linux) 

You can download NCIPLOT4 here: https://www.lct.jussieu.fr/pagesperso/contrera/nci-

programs.html  

The manual is at the download repository and also here: 

http://www.lct.jussieu.fr/pagesperso/contrera/nci-programs.html  

Basic run 

The minimum input for NCIPLOT is very simple: 

1. Number of files to be read 

2. Name of file(s) with extension .wfn for Gaussian calculations or .xyz for promolecular 

 

Example 

1 

file.wfn/xyz 

 

This will construct a paralepidid around the molecule: 

 

And evaluate the reduced density gradient on a grid. For illustrative purposes, we have used a 2x2x2 

grid in the ethane figure above. 

Greater number of files allow to estimate inter- and intramolecular interactions separately.For 

example, 2 files are used for analyzing intermolecular interactions between a ligand and a protein. 

This is done with an extra keyword after the previous lines: 

2 

ligand.xyz 

protein.xyz 

https://www.lct.jussieu.fr/pagesperso/contrera/nci-programs.html
https://www.lct.jussieu.fr/pagesperso/contrera/nci-programs.html
http://www.lct.jussieu.fr/pagesperso/contrera/nci-programs.html


INTERMOLECULAR 

 

Once the input constructed, the code is invoked as follows: 

nciplot.x < inputfile [> outputfile] 

The main results are collected in four output files: 

– name.dat file collects rho vs. RDG 

– name-grad.cube file with RDG 

– name-dens.cube file with sign(λ2) × ρ × 100 

– name.vmd is a script for visualization of the results in VMD 

Other options 

a) Adaptative grids 

NCIPLOT-4.0 features the implementation of the adaptive grid approach. Starting from a coarse grid 

to quickly explore the whole 3D space around the molecule, the user is prompted to define a 

succession of progressively finer grids to refine NCI results in regions where NCIs are actually 

detected. In this way, only NCI relevant points are computed accurately, resulting in a ∼ 10-fold 

speed-up. 

In order to use this option, the number of adaptative grids and their relative size (finishing with “1,” i. 

e., the basic INCREMENTS) are defined after the keyword CG2FG (Coarse Grid To Fine Grid). By 

default, the CG2FG option is set to 1 1 using only one level grid, i. e., without acceleration. In 

practice, we recommend to set CG2FG to 3 4 2 1 or 4 8 4 2 1 with 3- or 4-level grids for acceleration. 

This leads to an input looking as follows: 

1 

bigmolecule.xyz 

CG2FG 4 8 4 2 1 

 

b) Integrals 

A second feature that is new in NCIPLOT4 is the optional definition of integration ranges, to assess 

the relative strength of NCIs in different regions (attractive, repulsive and van der Waals) of the 

system. This tool will be referred to collectively as Non-Covalent Interaction Integrals (NCIIs). 

Starting from a standard 2D NCI plot, which allows the identification of NCIs by pairs of values of s 

and sign(λ2)ρ, integration regions can be defined as intervals on the sign(λ2)ρ axis, which correspond 

to a window on NCIs of a given strength range. Collective integration of ρ in such ranges provides a 

single number, a NCII, which represents a measure of the given interaction strength window. 

In order to define these ranges, the keyword RANGE is invoked, and the sign(λ2)ρ intervals 

subsequently defined: 



1 

bigsystem.xyz 

RANGE 3 

-0.1 -0.015 

-0.015 0.015 

0.015 -0.1 

This input defines 3 ranges of integration: [−0.1 −0.015], [−0.015 0.015] and [0.015 −0.1], to 

differentiate hydrogen bonds, van der Waals and steric crowding. 

Visualization: vmd 

Visualization is done through the cube files. We will be using vmd. Since visualization on the cluster 

might be slow, I recommend you copy all the visualization files (ELFCAR, .cube files) to your own 

computer and do the visualization locally. 

VMD is free for academics. You can download it here: 

https://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD 

Loading the file 

1-Go to the files location at the black vmd terminal: 

>cd dir (dir=your working directory) 

For example, I have transferred my files to a directory called “chembondlab” in my Desktop: 

 

You can use DOS commands, e.g. to to see what is inside the repository: 

>dir 

 

2-File > New Molecule>Browse 

You choose the name-dens.cube and click Load. Without closing the window, you now choose the 

name-grad.cube file and click Load.  

https://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD


 

 

It is very important that you follow this order so that both files are uploaded one on top of the other. 

You can verify that you did it correctly by looking at the main vmd window. 2 frames should appear 

for your file: 

 

 

Drawing the surface 

1-Graphics > Representations > Create Rep 

 

You can change the rendering of the molecule into balls and sticks: 



 

For a good quality picture, increase the sphere and bond resolution: 

 

Now let’s draw the NCI surface. 

>Graphics>Create rep 



 

And choose to draw the isosurface and its properties: 

a.Drawing Method : Isosurface 

b.Isovalue (0.3-0.5 are good values) 

c. Draw: Solid surface 

d. Coloring Method: Volume 

e.In Trajectory (3rd tab): Color Range Data Range :  

-3 3 

f. Show surface (or tap Enter key) 

  

In order to obtain the blue-green-red NCI colors you have to go to: Graphics > Colors > Color Scale 

and choose: BGR 



 

Other settings 

• Changing the background color to white 

Graphics>Colors>Display (in Categories)> 8 white (in Colors) 

• Getting rid of the axes 

Display>Axes>Off 

• Not showing perspective 

Display>Orthographic 

Saving your results 

• Saving your picture 

File > Render > Filename 

 

 
• Saving your state for ulterior use 

File > Nom du fichier: yourname.vmd 

 

Option 2: AIMALL (Windows) 

You can download a public license for AIMALL which can be used for up to 12 atoms following the 

instructions here: http://aim.tkgristmill.com/register.html  

Once you have installed it: 

1. Click on AIMStudio icon  

2. File> Open in New  window  

http://aim.tkgristmill.com/register.html


3. Run > AIMQB 

4. Isosurfaces > New 3D grid  

Choose: 

Function: |RDG|: Magnitude of the reduced gradient of the electron density 

 
5. File > Open in current Window 

Choose: “name_rdgm.g3dviz” 

 

 
6. The Isosurface option window will pop up. 

Choose: 

Values for isosurfaces=0.3-0.5 

Maximum electron density=0.7 

Map function: Sign(HessianRho_EigVal_2)*Rho 

Parent wavefunction file: name.wfn 

 

 
 

Note that the coloring is not the default one for NCIPLOT, but given as follows: 

 



 

 

 

Option 3: Jmol (Windows) 

You can download Jmol at: http://jmol.sourceforge.net/ 

 

You can proceed as follows: 

1. Click on Jmol.jar 

2. Open a console with File > Console 

 

 
 

3. Write in the console (+Intro) 

load "MethaneHF1-grad.cube" ↲ 
isosurface cutoff 0.5 "MethaneHF1-grad.cube" ↲ 
 

The cutoff is the isovalue that you can change at your wish. 

 

http://jmol.sourceforge.net/


 
 

 

 

 

4. You can map the density to color the isosurface as follows: 
 

isosurface parameters [0.5] "MethaneHF1-grad.cube" MAP 

"MethaneHF1-dens.cube" fullylit ↲ 
 

 

 
 

5. Other options for visualizing NCI are listed here https://chemapps.stolaf.edu/jmol/docs/examples-

12/new2.htm) 

Note that you can directly construct the promolecular NCI from the xyz! 

 

https://chemapps.stolaf.edu/jmol/docs/examples-12/new2.htm
https://chemapps.stolaf.edu/jmol/docs/examples-12/new2.htm
https://chemapps.stolaf.edu/jmol/docs/examples-12/new2.htm


 
 

 

 

Exercises 
In this exercise we will analyze non-covalent interactions in real molecules. If you have access 

to a Linux machine, you can download NCIPLOT here. If you are working under a Windows 

environment, you can register for a free version of AIMALL here. Note that the free AIMALL 

version does not allow more than 12 atoms, so you will not be able to do the second part of the 

exercise. AIMALL will enable you to have the densities of the NCI peaks. Visualization (but 

no quantification) is available with Jmol here. 

Exercises 1 and 2 can be carried out with any of the three codes. Exercise 3 (quantification) can 

only be carried out with NCIPLOT.  

  

1. Looking at the hydrogen molecule 
 

This exercise is a connection with the model system in the previous exercise. We will now study 

H2 molecule at several distances.  

1. Calculate NCI at d=2.0 and 2.5Å.1 Visualize the isosurface s=0.3 and a range in between -

3 to 3. What kind of interaction do you see for each distance? 

2. As we have seen in Exercise 1, we can also use NCI to visualize covalent interactions. It 

suffices to look at higher densities. You can do that by adding the CUTPLOT keyword in 

NCIPLOT:2 

1 

File.wfn 

CUTPLOT 2.0 0.3 

                                                           
1 You should calculate the wfn files first (e.g. CCSD/aug-cc-pvtz). If you cannot make wavefunction calculations 
use a promolecular density with an xyz format (explained in footnote 3). 
2 The value 2.0 corresponds to the density up to which interactions will be analyzed, i.e. =0-2.0 au will be 
plotted. The value 0.3 corresponds to the isosurface that will be analyzed if the vmd file is used. 

https://www.lct.jussieu.fr/pagesperso/contrera/nciplot.html
http://aim.tkgristmill.com/register.html
http://jmol.sourceforge.net/


You can also visualize it with AIMALL introducing the value 2.0 at the Maximum Electron 

Density entry. 

The difference from non-covalent to covalent is easy to visualize in the shape. What do 

changes do you observe? 

3. The color of the surface is given by the density. What is the density at the point s=0? You 

can use gnuplot to plot s() (information is in file.dat) or use AIMALL to calculate the 

density at the critical point (BCP) between the hydrogens (which is equivalent to the point 

s=0).  

 
Color Shape Density at s=0 

Interaction type 

(non-covalent/covalent) 

d=0.7 Å     

d=2.0 Å     

d=2.5 Å     

 

4. Instead of using wavefunction files, you can use xyz files with promolecular densities. This 

is easily done for example for 0.7 Å as:3 

2 

 

H 0.0 0.0 0.0 

H 0.0 0.0 0.7 

 

Do the same for d=2.0 and d=2.5 Å. Evaluate the agreement between the promolecular 

approximation and the real wavefunction. Do they agree better at long or short distances? 

Why? 

What is the difference between the functions used to describe the atoms with the 

promolecular approximation and the approach used with Python? 

2. Methane: analysis of different non-covalent interaction types 
 

Download the methane files. This exercise will enable you to see the difference between 

localized and delocalized interactions. Whereas localized interactions are mainly between two 

                                                           
3 The “2” corresponds to the number of atoms, then there is a blank line and finally, the list of xyz atom 
positions 



atoms (like the ones we saw for H2), delocalized one are between several atoms (so the surface 

spreads out). 

1. Visualize Methane dimer, CH4-H2O, CH4-HF and CH4-NH3. Which interaction is local 

(mainly between two atoms) or delocalized? 

Dimer NCI shape Interaction type 

(localized/delocalized) 

CH4- CH4    

CH4-H2O   

CH4-HF   

CH4-NH3   

 

3. Towards bigger systems and size dependency of non-covalent interactions 

 

Download the files for benzene, naphthalene and anthracene. These systems have one, two and 

three fused rings.  

1. Calculate NCI. Since in this case we are using rather big systems, we will choose 

promolecular densities, faster to calculate. We will further accelerate the calculation 

with an adaptative grid: 

2 

BenzeneA.xyz 

BenzeneB.xyz 

INTERMOLECULAR 

CG2FG 3 4 2 1 

 

2. Visualize the non-covalent interactions in the parallel conformation (P) and the T-shape 

conformation (T) for benzene and classify them as delocalized or localized. 

3. Visualize now naphthalene and anthracene P and T conformations. What happens as the 

size increases for each interaction type? 

4. You can quantify this effect with NCIPLOT. Use the following input type to obtain the 

volume of the non-covalent interactions the parallel and T-shape series with respect to 

the number of units (from 1 unit in benzene to 3 in anthracene).  

 

 



INPUT EXAMPLE: 

2 

BenzeneA.xyz 

BenzeneB.xyz 

INTERMOLECULAR 

RANGE 3 

-0.07 -0.01 

-0.01 0.01 

0.01 0.07 

 

OUTPUT EXAMPLE: 

 

According to this output, the volume of the NCI region in benzene dimer is 0.70727487 

au. 

 

Benzene units Parallel conformation 

volume integral 

T-shape conformation 

volume integral 

1   

2   

3   

 

Plot these data. What interaction becomes favored with size? Check the fit to a straight 

line of the local interaction, what does this mean? 

 

 

 

---------------------------------------------------------------------- 

                     INTEGRATION DATA 

---------------------------------------------------------------------- 

 Integration  over the volumes of rho^n 

---------------------------------------------------------------------- 

 n=1.0           :        0.70727487 


